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Keyboard

The keyboard functions essentially the same as for any windows application.    The only 
unique feature of the keyboard interface involves selecting items and launching applications.
Use the left and right arrow key to move from item to item.    Hitting return will execute the 
selected item.    If the folder is set to listbox display mode, that is it has the icons turned off, 
the up and down arrow keys may also be used.    Note that multiple items may only be 
selected by using the mouse.



Folder Commands

To get help with a command, choose the appropriate menu.

File Menu
    New
    Open
    Save
    Save Config
    Name
    Delete
    Run
    Exit

Edit Menu
    Add Item
    Delete Item
    Delete File and Item
    Delete Subfolder
    Move
    Copy
    Command Line
    Filename

Special Menu
    Item Name
    Item Icon
    Set Default Icon
    Associate
    Arrange Icons
    Preferences



Folder Procedures

The Procedure topics give you detailed instructions on using the commands available to a 
folder.

Working with folder items
Adding items to a folder
Changing an item's icon
Changing an item's name
Copying items from folder to folder
Deleting a folder item
Deleting a folder's item and its file
Editing/viewing an item's file name
Executing an item
Moving items from folder to folder
Setting an item's command line
Setting the default icon

Group Level Folder Procedures
Creating a new folder
Deleting a group level folder
Renaming a group level folder

Other
Associating programs with file extensions
Creating a new folder
Exiting a folder
Opening a folder
Saving a folder
Saving a folder's configuration
Setting the folder icon
Setting the password
Using the Preferences command
Using the Run command



File Menu

New - This command create a new folder.    This can be either a subfolder or a group level 
folder.    Group level folders appear as icons in the group specified during the creation 
process.    Subfolders appear as icons in the folder currently opened.    Note that you can 
create subfolders in subfolders with essentially no limit on nesting folders within folders.    Be
sure and give each folder an unique name.    Changing the case of a letter will not make a 
name unique.

Open - This command allows you to open or activate, if already open, any folder on the 
system, regardless of its location .    This allows you to open a specific folder without having 
to hunt it up.

Save - This command saves any changes made to the folder.    Note that some commands 
will automatically perform a save when executed.    They include delete subfolder, rename a 
subfolder, create a subfolder. 

Save Config - The current configuration of a folder may be saved using this command.    
The configuration includes the size of the folder, the position of the folder and the location of
the items in the folder.    Exactly which of these quantities are saved can be set using the 
Preferences command under the Special menu.

Name - Using this command, a group level folder may be renamed.    It is grayed out in 
subfolders.    Subfolders must be renamed by their parent folder using the Special menu 
command,    Item Name.    Note that the folder icon in the Program Manager group must also 
be renamed using the PM's properties command.

Delete - This command will delete the group level folder currently open.    That is the folder 
from which this command is executed will be deleted.    Like Name it only works for group 
level folders.    Subfolders are deleted using the Edit menu command, Delete Subfolder from 
the parent folder.    Two important points to note with this command are, first, no subfolders 
are deleted.    To prevent having any unwanted subfolders left, they must be deleted before 
this command is executed starting from the lowest level.    Second, the folder icon in the 
Program Manager group must be deleted using the PM's delete command.

Run - Allows the user to enter a command line to be executed.    The last twelve commands 
entered are stored for easy access.

Exit - Causes the current folder to be closed.    If has not been saved, and changes have 
been made, you will be prompted on whether or not you want the folder saved.



Edit Menu

Add Item - Adds items to the current folder.    A dialog box is presented from which you may 
choose any file on the system.    After choosing, a descriptive name for the item must be 
entered.    This is the name that will show up under the item's icon.    An icon will then appear
which represents the item just added.    By double-clicking on this icon, the item may be 
executed.    Multiple items may be added by clicking on each file in the file listbox you wish 
to add.    Clicking on a selected file will de-select it.

Delete -
Item - This command removes the selected item from the folder.    It does not delete the 
file associated with the item.    It simply removes it from the folder.    If multiple items have 
been selected, a prompt to delete or not appears for each item selected.

File and Item - This command removes the item from the folder and deletes the file 
associated with the item.    As such, use it only when you wish to remove the file 
completely from the disk.    If you wish to only remove the item from the folder, use the 
Delete Item command.    This command does not function with subfolders.    If multiple 
items have been selected, a prompt will appear as to whether or not to delete it for each 
item selected.

Subfolder - Use this command to delete a subfolder.    Note that this command 
completely removes the subfolder.    As such, if you have copied it to another folder and 
wish to be able to still access it from this other folder, use the Delete Item command to 
remove it from the current folder rather than this command.    Also, any subfolders in this 
subfolder are NOT deleted.    So be sure and delete these other subfolders, first.

Move - This command moves the currently selected item to the folder specified.    In doing 
so, it is removed from the current folder.    Note that if the folder you are moving the item to 
is open, it must be closed and reopened before the new item will appear.    This commands 
will work on any item including subfolders.    If multiple items are selected, all items selected 
are moved.    Items may also be moved by dragging them with the mouse to the desired 
folder, which must also be open.

Copy - Works the same as move, but does not remove the item from the current folder.    If 
multiple items are selected, all items selected are copied.    Use this command to link two or 
more folders to the same subfolder.    Simply create the desired subfolder using the File 
menu New command.    Then copy the new folder item to whatever other folders you wish to 
be able to access it.    Items may also be copied by dragging them with the mouse to the 
desired folder.    The right mouse button must be held down when releasing to left mouse 
button for the items to be copied, otherwise they will be moved.

Command Line - Allows you to customize a command line for an item.    Note that this 
command line takes precedence over the file name.    That is, if you have an item whose file 
is LETTER.TXT and TXT files are associated with Notepad, normally executing this item would
cause Notepad to be ran using the file as the data file.    However, if you specify the 
command line as WRITE.EXE LETTER.TXT, the program Write will be ran rather than Notepad.
By setting the command line to blank, the original functionality of the item will be returned.   
Note that any type of command may be specified on the command line.

Filename - This command shows the actual DOS file associated with an item.    As the item 
name need not be at all similar to the file name, this command is useful to find out what the 
actual file is.    The filename may also be edited thru the use of this command.



Special Menu

Item Name - This command allows you to rename items and subfolders.    When renaming 
subfolders, an automatic save will be performed.

Item Icon - Allows you to specify which icon is to be used to represent an item.    This may 
be any icon located in an ICO file, an EXE file or an ICL file (icon library).    From the dialog 
box presented, locate the file with the desired icon and read in the icons using the Read File 
button.    From the displayed icons select the desired one.

Set Default Icon - This command allows you to associate an icon with a file extension.    
Doing so, will cause the specified icon to be used to display any item with that particular 
extension unless the item's icon has been set with the Item Icon command.    The new 
associations will not appear until the folder is closed and reopened.    This is true for any 
folder that was open when the changes were made.    Once set, any item with the specified 
extension will appear using the icon associated with that extension.

Associate - The associate command is similar to the Associate command in File Manager.    
It can be used to associate a particular program with a specified file extension.    Whenever 
you execute an item the program associated with the item's file extension will be ran using 
the item as the data file.    Unlike the File Manager's command, multiple programs may be 
assigned to a single extension.    Executing an item with multiple programs assigned to it will
cause a listbox to appear from which the desired program to be ran may be chosen.

Arrange Icons - Arranges the folder icons in an orderly manner.

Preferences - This command allow the folder to be customized.    What aspects of a folder 
that are saved when using the Save Config command may be set from this command.    Also,
the folder can be set to minimize or close on execution of an item in the folder.    Auto 
arrange of icons can be turned on or off from this command.    Note that if auto arrange is on,
the icons will be re-arranged everytime the folder is resized or minimized.    The display 
mode to be used, icons or listbox may be set from this command.    Also, a password may be 
assigned to the folder.    Finally, the icon to be used to represent folder may be set.    Once a 
new icon is assigned to the program, all subfolders and minimized folders will appear using 
this icon.    However, any folder icons in Program Manager groups will still need to be set by 
hand.    



Customer Support

Customer support is available to all registered users of Folders for as long as you own the 
program.    Support is also available to unregistered users during their thirty day trial period.

Support may be obtained by calling (719) 260-0433 during normal business hours.    Please 
leave a message should we be unable to answer the call immediately.    We promise to get 
back to you that same day if at all possible.

You may also write us at:

Sloop Software
Customer Support
6457 Mesedge Lane
Colorado Springs, CO 80919

Or by sending email to CompuServe, id 72540,144 or Internet 72540.144@compuserve.com.
We check CompuServe on a daily basis allowing for a prompt response to any inquiries.

Please include as many details as possible concerning any problem you may be experiencing
to allow us to fix it as quickly as possible.

This program is produced by a member of the Association of Shareware Professionals (ASP).   
ASP wants to make sure that the shareware principle works for you.    If you are unable to 
resolve a shareware-related problem    with an ASP member by contacting the member 
directly, ASP may be able to help.    The ASP Ombudsman can help you resolve a dispute or 
problem with an ASP member, but does not provide technical support for members' 
products.    Please write to the ASP Ombudsman at 545 Grover Road, Muskegon, MI 49442 or 
send a CompuServe message via CompuServe Mail to ASP Ombudsman, 70007,3536.



Registering Folders

Folders is a shareware program.    As such, you may use it on a trial basis for thirty days.    
After this time, the program should be registered if it is continued to be used.    The cost is 
thirty-five dollars for the latest version and a printed manual or thirty dollars without the 
manual.    Please include an additional two dollars for shipping and handling.    The fee is 
payable to:

              Sloop Software
              6457 Mesedge Lane
              Colorado Springs, CO 80919
              (719) 260-0433

Be sure and specify your name, address, name of the program and where you obtained the 
program when registering.    Also, specify 3.5" or 5.25" disk.    Colorado residents, please add 
six percent sales tax.    Sorry, no credit cards.

Direct any    comments to the above address or email to CompuServe 72540,144, or Internet 
72540.144@compuserve.com.    Customer support is available to registered users and to 
unregistered users during their trial period.

For information on availability and pricing of a Japanese version contact:
 
            Personal Data Factory
            Shinjuku yubinkyoku dome
            160 Tokyo Japan



License Agreement

No part of this manual may be reproduced, transmitted, transcribed, stored in a retrieval 
system, or translated into any language (natural or binary), in any form or by any means, 
except as described in the following license agreement or without the express prior written 
consent of Sloop Software.
                                                      
The use of Folders is subject to the following terms and conditions.

Title To The Licensed Software
Title to the licensed software is NOT transferred to the end user. The end user is granted an 
exclusive license to use the software on a SINGLE computer or computer work station. EACH 
computer or computer work station must have its own licensed copy of the software.

Copyright Protection
Folders is copyrighted material. It is protected by the copyright laws of the United States, 
the State of Colorado, and other proprietary rights of Sloop Software. You may not make any 
changes or modifications to Folders or this manual. You may not decompile, disassemble, or 
otherwise reverse-engineer the software in any way.

You may make copies of Folders only under the terms of the section entitled "Limited License
To Copy The Licensed Software".

You may use Folders on a trial basis provided you do not violate the protection afforded the 
licensed software by the copyright laws, and you agree to the terms of the license 
agreement. If you use Folders on a regular basis you are obligated to purchase it.

Limited Warranty
Sloop Software does not warrant that the licensed software will meet your requirements or 
that the operation of the software will be uninterrupted or error free.    The warranty does not
cover any media or documentation which has been subjected to damage or abuse by you.

The software warranty does not cover any copy of the licensed software which has been 
altered or changed in any way.

ANY IMPLIED WARRANTIES INCLUDING ANY WARRANTIES OF MERCHANTABILITY OR FITNESS 
FOR A PARTICULAR PURPOSE ARE LIMITED TO THE TERM OF THE EXPRESS WARRANTIES. 
Some states do not allow limitations on how long an implied warranty lasts, so the above 
limitation may not apply to you.

Other Warranties
The warranties set forth above are in lieu of any and all other express or implied warranties, 
whether oral, written, or implied, and the remedies set forth above are the sole and 
exclusive remedies.

Limitation Of Liability
Sloop Software is not responsible for any problems or damage caused by the licensed 
software that may result from using the licensed software. This includes, but is not limited 
to, computer hardware, computer software, operating systems, and any computer or 
computing accessories. End user agrees to hold Sloop Software harmless for any problems 
arising from the use of the software.

Sloop Software SHALL NOT IN ANY CASE BE LIABLE FOR ANY SPECIAL, INCIDENTAL, 
CONSEQUENTIAL, INDIRECT OR OTHER SIMILAR DAMAGES ARISING FROM ANY BREACH OF 



THESE WARRANTIES EVEN IF Sloop Software OR ITS AGENTS OR DISTRIBUTORS HAVE BEEN 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.    Some states do not allow the exclusion 
or limitation of incidental or consequential damages, so the above limitation or exclusion 
may not apply to you.

In no case shall Sloop Software's liability exceed the license fees paid for the right to use the
licensed software, or a sum no greater than one Dollar ($1.00), whichever is less.

Limited License To Copy The Software
You are granted a limited license to copy Folders ONLY FOR THE TRIAL USE OF OTHERS 
subject to the terms of this software license agreement described herein, and the conditions 
described below are met: Folders MUST be copied in an unmodified form and FOLDERS.ZIP 
MUST contain the following files:

          FOLDERS.EXE - the Windows executable program (shareware version only)
          FOLDERS.WRI - the program documentation
          README.TXT - installation information
          FOLDERS.INI - Folders initialization file
          FOLDER.HLP - Folder help file
          FLD0000.FL0          - empty folder for manual installation process
          FINSTALL.EXE - Folders install program
          FOLDERS.ICL - Folders icon library
          ORDERFRM.TXT - Folders order form
          VENDOR.DOC - shareware vendor information

-> No fee, charge or other compensation may be accepted or requested by anyone without 
the express written permission of Sloop Software.

Public Domain Disk Vendors May NOT CHARGE a fee for Folders itself. However you may 
include Folders on a diskette for which you charge a nominal distribution fee. The purchaser 
of said diskette must be informed in advance that the fee paid to acquire the diskette does 
NOT relieve said purchaser from paying the registration fee for Folders if said purchaser uses
Folders.

-> Operators of electronic bulletin board systems (Sysops) may post Folders for downloading
by their users without written permission ONLY AS LONG AS THE ABOVE CONDITIONS ARE 
MET.    A fee may be charged for access to the BBS AS LONG AS NO SPECIFIC FEE IS 
CHARGED FOR DOWNLOADING Folders files without first obtaining express written 
permission from Sloop Software to charge such a fee.

The above constitutes the license agreement for Folders. It supersedes any and all previous 
license agreements.



Notes on using icons

Folders allows you to use icons present in ICO files, EXE files and ICL files.    ICO files contain 
a single icon, while EXE's and ICL files may contain one or more icons that may be used.    A 
icon library, folders.icl, is included with the program for your use.    To use it, simply copy it to
the folders data directory.    Everytime you use the Item Icon, or Set Default Icon command, 
the icon dialog box will initially present all the icons in the folders.icl for you to choose from.  
If the icon you wish to use is not present, simply select the file which does have the desired 
icon and hit Read File.    Note that you may basically do anything you wish with the folders.icl
file without impacting Folders operation.    It may be deleted, copied over or edited with a 
program like Icon Manager or equivalent.    If it is not present, you will simply not have any 
icons to choose from initially on executing an icon command.

Hierarchy of icons:    There is a hierarchy involved in Folders deciding which icon should be
used to represent an item.    At the top-level, if an item has had an icon explicitly set for it 
using the Item Icon command, this icon will always be used regardless of any other settings 
made.    Next, if the item does not have an icon set for it, but does have an icon associated 
with its extension, this icon will be used.    Finally, if neither of the above is true, if the item is
an executable or is associated with an executable, the icon for that executable will be used.   
If none of the above holds, the item will appear using the default icon, which is the DOS icon.

Limitations: There may be cases where, for some reason, Folders just cannot find the icon 
in the specified file (eg. WINWORD).    In order to use such an icon, you will need to convert it
into an ICO file using some utility such as Icon Manager.    Once this is done, simple specify 
the ICO file created to use the icon.

Troubleshooting: Should you be using a 256 color display and the icons are not displaying 
correctly, try this fix.    In the FOLDERS.INI file, under [Defaults] should be a line that reads 
'Color Mode=0'.    Change the 0 to 256.    This should allow the icons to diplay correctly.    
Note that Folders will only work in 256 mode now.    To run in 16 color mode, change the 
number to 16 or 0, for auto-sensing of the color mode.    If your INI does not have the color 
mode line, simply add it in to the [Defaults] section.

Related Topics
      Changing an item's icon
      Setting the default icon



Adding items to a folder

1. Select Add Item from the Edit menu.
2. From the dialog box that appears, choose the file you wish to add.    Multiple files may be 
selected by simply clicking on each file to be added.    To deselect a file, click on it again.    All
highlighted files will be added.    Click on OK.
3. Enter the descriptive name for the item that you wish to have appear under the item icon. 
If multiple items were selected, a input box will appear for each item, one after the other.
4. The new item(s) should now appear as an icon in the folder.



Changing an item's icon

1.    Select the item whose icon you want to change    by clicking on it with the mouse.
2.    Select Item Icon from the Special menu.
3.    From the dialog box, choose the new icon to be used to represent the selected item.    To 
use an icon in a specific file, select the file using the file listbox.    Click on Read File to 
display all icons in the selected file.    In the icon listbox, select the desired icon and click on 
OK.
4.    The item should appear with the new icon.

Related Topics
      Notes on using icons
    Setting the default icon



Changing an item's name

1.    Select the item you wish to rename by clicking on it with the mouse.
2.    Select Item Name from the Special menu.
3.    Type in the new name you want for the item.    Click on OK.
4.    The item's name will change to show the new name.

This command is also used for changing the names of subfolders, but not group level 
folders.

Related Topics
    Renaming a group level folder



Copying items from folder to folder

1.    Select the item you wish to copy by clicking on it with the mouse.    Multiple items may 
be selected by holding down the CTRL key while clicking on each item.
2.    Select Copy from the Edit menu.
3.    From the dialog box, select the folder you want the item copied to.    Click on OK.
4.    The item will now be copied to the specified folder.

or
1. Make sure the folder you wish to copy the selected items to is open or is a subfolder of the
current folder.
2. Select the items to be copied in the same manner as above, but on the last item selected 
continue to hold down the left mouse button.
3. Drag the cursor to the folder you wish to copy the items to.    The cursor will be a 
monochrome version of the selected item if only a single item is selected.    If multiple items 
are selected, it will be a generic drag item cursor.
4. While holding down the right mouse button, release the left mouse button while the 
cursor is over the folder you want to copy the items to.    If the cursor is a circle with a line 
across it, you are over an illegal drop point.
5. Once the left mouse button has been release, the right mouse button may also be 
released.    The selected items will be copied to the specified folder.

Using this command, one can link the same subfolder to two or more other folders.    Simply 
copy the subfolder to the folder you wish to also have access to it.

Related Topics
    Moving items from folder to folder



Creating a new folder

1.    Select New from the File menu.
2.    Enter the name of the new folder.    This name MUST be unique.    Upper or lower case do 
not make any difference.
3.    Select whether you wish this to be a subfolder or a group level folder.    Subfolders can 
only be accessed from the folder creating it.    They appear as a folder icon in the parent 
folder.    Group level folders are accessed from the Program Managers groups.    They appear 
as a folder icon in the group selected.
4.    If creating a group level folder, you will be prompted to enter the name of the Program 
Manager group you wish the folder to appear in.    This can be an already existing group or 
an entirely new group.    If it is a new group, the group will be created and the folder placed 
in it.    Once a group level folder has been created, it can be moved from group to group just 
like any other group item.

Related Topics
      Deleting a group level folder
      Deleting a subfolder



Deleting a folder item

1.    Select the item you wish to delete by clicking on it with the mouse.    Multiple items may 
be selected for deletion by holding down the CTRL key while clicking on each item to be 
deleted.
2.    Select Delete Item from the Edit menu.
3.    You will be asked if you wish to delete the selected item.    Click on Yes or No.
4.    If you clicked on Yes, the item will be deleted from the folder.    Note that if you 
accidentally delete an item, close the folder without saving it.    When you reopen it, the item
will still be there.

Related Topics
      Deleting a folder's item and its file
      Deleting a group level folder
      Deleting a subfolder



Deleting a folder's item and its file

1.    Select the item you wish to delete by clicking on it with the mouse.    Multiple items may 
be selected for deletion by holding down the CTRL key while clicking on each item to be 
deleted.
2.    Select Delete File and Item from the Edit menu.
3.    You will be asked if you want to delete the selected item and its file.    Click on Yes or No.
4.    If you clicked on Yes, the item will be removed from the folder and the item's associated 
file will be erased from the disk.

Related Topics
      Deleting a folder item
      Deleting a group level folder
      Deleting a subfolder



Deleting a group level folder

1.    Select Delete from the File menu.    Note that this command is only operational from a 
group level folder.
2.    You will be asked if you want to delete the folder.    Click on Yes or No.
3.    If you clicked on Yes, the folder will be closed and deleted from the system.    You must 
then also delete the folder icon from the Program Manager .

Note that subfolders contained in this folder will NOT be deleted.    Unless they are linked to 
some other folder, they should all be deleted using the Delete Subfolder command before 
deleting the folder.

Related Topics
      Deleting a folder item
      Deleting a folder's item and its file
      Deleting a subfolder



Deleting a subfolder

1.    Select the subfolder you wish to delete by clicking on it with the mouse.
2.    Select Delete Subfolder from the Edit menu.
3.    You will be asked if you want to delete this subfolder.    Click on Yes or No.
4.    If you clicked on Yes, the subfolder will be removed from the system.    Note that if the 
subfolder has been copied to other folders, it must be removed from those folders using the 
Delete Item command.

Note that any subfolders contained in the subfolder being deleted will NOT be deleted.    
They should be removed thru use of this command before deleting the subfolder they are 
contained within.

Related Topics
      Deleting a folder item
      Deleting a folder's item and its file
      Deleting a group level folder



Executing an item

1.    Double-click on an item's icon to execute it.
                  or
2.    Click on it with the mouse and hit the enter key.
                  or
3.    Use the arrow keys to select the item.    Hit    the enter key.



Exiting a folder

1.    Select Exit from the File menu or Close from the System menu.
2.    If changes have been made to the folder since the last save, you will be prompted for 
whether or not you wish to save the folder.    Clicking on Yes will save and exit the folder.    
Clicking on No will exit the folder without saving.    Clicking on Cancel will cancel the exit 
operation and return you to the folder.



Moving items from folder to folder

1.    Select the item you wish to move by clicking on it with the mouse.    Multiple items may 
be selected by holding down the CTRL key while clicking on each item.
2.    Select Move from the Edit menu.
3.    From the dialog box, select the folder you want the item moved to.    Click on OK.
4.    The item will now be moved to the specified folder.

or
1. Make sure the folder you wish to move the selected items to is open or is a subfolder of 
the current folder.
2. Select the items to be moved in the same manner as above, but on the last item selected 
continue to hold down the left mouse button.
3. Drag the cursor to the folder you wish to move the items to.    The cursor will be a 
monochrome version of the selected item if only a single item is selected.    If multiple items 
are selected, it will be a generic drag item cursor.
4. Release the left mouse button while the cursor is over the folder you want to move the 
items to.    If the cursor is a circle with a line across it, you are over an illegal drop point.    
The selected items will be moved to the specified folder.

Related Topics
    Copying items from folder to folder



Opening a folder

1.    Select Open from the File menu.
2.    Choose the folder you wish to have opened from the list in the dialog box.    Click on OK.
3.    If the folder selected has not been previously open, it will be opened and appear in a 
second window.    If it is already open, it will be made the active window.    If is already open 
and minimized, its icon will be opened into the active window.



Renaming a group level folder

1.    Select Name from the File menu.    Note that this command is only for renaming group 
level folders.    Subfolders should be renamed from the parent folder using the Item Name 
command in the Edit menu.
2.    Enter the new name for the folder.    This name must be a unique folder name.    Click OK.
3.    Rename the folder's icon in the Program Manager group using the PM's Properties 
command in the File menu.

Related Topics
    Changing an item's name



Saving a folder

1.    Select Save from the File menu.
2.    All change made to the folder will be saved except for configuration information.    Only 
the Save Config command will save this type of information.

Related Topics
        Saving a folder's configuration



Saving a folder's configuration

In order to save a folder's size or position, or the position of the items in the folder, a Save 
Config command must be executed.    The exact information saved is determined by the 
options selected using the Preferences command.    Performing a Save command will not 
save any of the configuration information.    Note that this command has the same effect as 
a Save command as well.

1. Select Save Config from the File menu.
2. Any changes made to the folder as well as the specified configuration information will be 
saved.

Related Topics
      Saving a folder
      Using the Preferences command



Setting an item's command line

1.    Select the item whose command line you wish to set by clicking on it with the mouse.
2.    Select Command Line from the Edit menu.
3.    Enter the new command line you want to be ran when the item is executed.    Click on 
OK.

Entering a blank line will set the item back to its original functionality before the command 
line was set.



Setting a default icon

1.    Select the item whose file extension you wish to assign a default icon to.
2.    Select Set Default Icon from the Special menu.
3.    Choose the icon you want associated with the extension from the icon listbox presented. 
To use an icon in a specific file, select the file in the file listbox and click on Read File.    From 
the icons presented, select the desired icon.
4.    To see the new icons, close and reopen the folder.

Note that these associations will apply to all folders, not just the one they are set in.    To 
remove any association previously set the FOLDERS.INI file must be edited.    Open it with a 
text editor like notepad.    Under the section [Icon Extensions] delete the line containing the 
extension you wish to de-associate.    Save the file.    The items should now appear using 
their old icons.    To clear all default icons assigned, simply delete the file FOLDERS.DFI in 
your folders data directory.

Related Topics
      Changing an item's icon



Setting the folder icon

1. Select the Preferences command from the Special menu.
2. Click on the Folder Icon button.
3. From the icon browse box select the icon to be used as the folder item icon.    Click on OK.
4. All folders should now be closed to allow the change to take effect.

Related Topic
    Using the preferences command



Setting the password

1. Select the Preferences command from the Special menu.
2. Click on the Password button.
3. Enter the desired password in the input box.    Click on OK.
4. Once the password is set and saved, every time the folder is opened the password will 
need to be entered before the folder will open.

To clear a password, perform steps 1 and 2 above, but instead of entering a password, 
simply leave the line blank and click on OK.    The password will then be cleared.

Note that this password scheme is not unbreakable.    It will keep out most users, but a 
determined computer professional will be able to break it.

Related Topic
    Using the preferences command



Editing an item's file name

1.    Select the item whose file name you wish to view by clicking on it with the mouse.
2.    Select View Filename from the Edit menu.
3.    A dialog box will appear showing the file associated with the folder item will appear.    At 
this point the filename may be edited.    Click on OK to set the new name.



Associating programs with file extensions

Application programs may be associated with a particular file extension.    For example, 
Notepad may be associated with TXT files.    Executing a file with a program associated with 
its extension will cause the associated program to be ran using the file as the data file.    For 
instance, if TXT is associated with Notepad, running the file readme.txt would cause Notepad
to run and load the file readme.txt.    Folders provides a command to form such associations. 
It is similar to the File Manager command, with the exception that it is able to associate 
more than one program to an extension.

To associate a program, follow these steps:
1. Select the folder item whose filename's extension you wish to asscociate a program with.
2. From the Special menu, select the command Associate.
3. A dialog box will appear in which you may enter the name of the program you wish to 
associate or the program may be selected using the Browse button.
4. If an association already exists, the option to append the new association will be 
available.    To do so, click on the check box 'Append association'.        Click on OK.    This will 
cause the new association to be added to the list of programs associated with the selected 
extension.
5. If you wish overwrite the current association, or if there is no previous association, leave 
the check box unchecked and click on OK.
6. If you wish to view any other associations that have been previously set, click on the 
down arrow at the right of the input box.    A list of all other associations that have been set 
will appear.    To close the list, simply click on the down arrow again.

Notes:    If multiple programs have been assigned to an extension, whenever you execute an 
item with that file extension, a listbox will appear showing all the programs that have been 
associated with the extension.    Simply double-click on the program you wish to execute.

To remove a previously set association, follow steps 1 thru 3, but on step 3 click on the down
arrow at the right of the input box.    From the list of associations that appear, click on the 
association you wish to remove.    The program selection should appear in the input box.    
Click on OK and the association selected will be removed.



Using the Run command

1. Select Run from the File menu.
2. In the dialog box that appears, type in the command you wish to execute.    Or, use the 
browse button to select a file to be executed.
3. Click on OK.    The command entered will be executed.

Notes: The Run command stores the last twelve commands executed, throwing out 
duplicates.    When the Run command is selected, the last command entered using the Run 
command will automatically appear in the input box.    To execute it, simply click on OK.    To 
access the other eleven commands stored, click on the down arrow at the right of the input 
box.    A list will appear containing the other eleven commands.    Click on the command you 
wish to execute, and then click on OK.    The command will be ran.



Using the Preferences command

1. Select Preferences from the Special menu.

2. From the dialog box presented, several options may be set to customize the folder as 
explained below.

Save Configuration options: When executing a Save Config command, the choses 
selected here will govern what information about the folder is saved.    Information that
can be saved include the folder size and position, and the position of the folder items.   
Any option not selected will not be saved.    Note that performing just a Save will not 
save any of this information.

Minimize on use, Close on use options: Selecting one of these will cause the folder to 
be either minimized or closed when an item in the folder is executed.

Auto Arrange switch: When this option is activated, the folder item icons will 
automatically be rearranged whenever the folder is resized or minimized.    If you wish 
to keep the folder items in specific locations at all times, do not use this option.

Icons off: This option, when set, will cause the folder items to be displayed using only 
their names.    No icons will be displayed.    This mode is the listbox display mode.    If 
this option is not set, all items will be displayed using icons.

Show extensions: When in listbox display mode, the item file extensions will be 
displayed as part of the name if this option is set.

3. Once you have chosen the options you with to be active for this folder, click on OK to 
return to the folder window.    Note that a Save or a Save Config must be performed for the 
preferences to be saved.

4. Besides setting the options for the current folder, one may also set the default options 
that will be used whenever a new folder is created.    Simply choose the options you wish to 
be used and click on Set Defaults.    Any new folder created will automatically have these 
particular options already set.    Note that the current folder will also now have these options.

5. If you wish to set a folder's preferences to whatever you have set as the default as 
explained in 4 above, simply click on Reset Settings.    The folder will now have the same 
preferences as the defaults.

6. The folder icon to be used may also be set from this dialog box.    Clicking on the Folder 
Icon button allows the icon used to represent a folder to be changed to any icon available on
the system.    A dialog box is presented to choose an icon from in the same manner as the 
Item Icon command.    Once the icon is set, all subfolders and all minimized folders will 
appear using this icon.    Folder icons in Program Manager groups must still be set by hand.    
After executing this option, all folders should be closed to allow it to take effect.

7. Finally, a password may be assigned to the folder thru the use of the Password button.    
Clicking on it will produce a dialog box in which you may enter the desired password for this 
folder.    The next time the folder is opened, this password will need to be entered before you
will be able to access the folder.    To clear the password, simple select this function again 
and enter a blank line for the password.


